Won't restart when warm

This is the place to get help with technical matters concerning your M151 jeep

Moderators: rickf, Mr. Recovery, raymond, moose53

Won't restart when warm

Sponsor

Sponsor
 

Won't restart when warm

Postby mallard » November 13th, 2017, 11:34 pm

I sent my carb to Rick to have him work some magic on it but it appears it might be to far gone. While waiting a friend offered to let me borrow a new carb he had laying around. After I installed it I noticed the diaphragm on the side was letting air in. I changed the diaphragm and installed it in this order carb-diaphragm-spring-cover. Now after getting up to temp if I shut it off and wait 2-20 minutes it doesn't want to restart. Some times working the choke back and forth it will crank after a little while and I get a nice puff of smoke from the exhaust. When cold it cranks right up no problem. It doesn't appear to have any issues while driving however I've only driven on gravel and not over 30mph.
I swapped the coil and both the old and new usgi measured 6.0 ohms. I pulled the pcv valve and cleaned it out. Any ideas on which way to go on this? Thanks for all the help.
1965 M151A1
mallard
Staff Sergeant
Staff Sergeant
 
3 years of membership3 years of membership3 years of membership
 
Posts: 101
Joined: May 11th, 2014, 10:53 am
Location: central Arkansas

Re: Won't restart when warm

Postby rickf » November 14th, 2017, 8:08 am

The accelerator pump (the diaphragm you replaced)only works when the engine is running so it is common to have to use the choke to start the engine. Do you have the intake hose to the air cleaner hooked up? When you shut the engine off the pump shoots a shot of gas into this hose so there is a little gas there to assist in starting. No hose, no gas. Pumping the gas pedal before you start it like you would on most old cars does not work on a 151. Once warmed up they usually start without touching the gas but each one is different. Try starting it without touching the gas pedal at all when it is warm, unless the idle is set too low that should work fine.
1964 M151A1
1984 M1008
1967 M416
04/1952 M100
12/1952 M100- Departed
AN/TSQ-114A Trailblazer- Gone
rickf
General
General
 
9 years of membership9 years of membership9 years of membership9 years of membership9 years of membership9 years of membership9 years of membership9 years of membership9 years of membership
 
Posts: 14182
Joined: November 26th, 2007, 12:28 pm
Location: Pemberton, NJ.

Re: Won't restart when warm

Postby Horst » November 14th, 2017, 4:03 pm

when mine does not want to start warm which it sometimes does, I have to push full throttle and start it. So try both ways :)
Horst

1972 USMC M151A2 w/ROPS and M416
1962 M201 and trailer
1966 Pontiac GTO
1987 Suzuki Samurai
1987 911
Gone: 2xM35A2c, Unimog 404S, Hanomag AL28, DKW Munga
User avatar
Horst
Colonel
Colonel
 
9 years of membership9 years of membership9 years of membership9 years of membership9 years of membership9 years of membership9 years of membership9 years of membership9 years of membership
 
Posts: 1402
Joined: December 9th, 2007, 5:21 am
Location: Munich, Germany

Re: Won't restart when warm

Postby mallard » November 14th, 2017, 4:15 pm

Thanks for both tips, one thing I noticed was it was more likely to start if I pressed the starter button and let it turn over a couple times before I flipped the ignition switch. If it didn't start quickly alternating the ignition lever on and off it would seem to start more as soon as the lever was switch on. Doesn't make much sense to me but it worked. Once running it stays running good.
1965 M151A1
mallard
Staff Sergeant
Staff Sergeant
 
3 years of membership3 years of membership3 years of membership
 
Posts: 101
Joined: May 11th, 2014, 10:53 am
Location: central Arkansas


Return to Technical Discussion

Who is online

Users browsing this forum: Bing [Bot], fergrn37, fowlercal and 1 guest

Customization by G838.org