Turn signal light permanently on

This is the place to get help with technical matters concerning your M151 jeep

Moderators: rickf, moose53, Mr. Recovery, raymond

Post Reply
on-to-berlin
Sergeant First Class
Sergeant First Class
Posts: 236
Joined: December 1st, 2011, 1:54 pm

Turn signal light permanently on

Post by on-to-berlin » May 27th, 2018, 12:31 pm

Good Evening!
Now that I wanted to do my first long distance trip with my newly restored A2 I have an electric problem. When I use the turn signal switch the little green light on the turn switch goes on permanently.
It doesn´t matter if I want to do a right, left turn or push it all the way up for emergency lights.
My first idea was that the turn switch itself is not working. So I changed that. But that wasnßt the cause. Then I changed the flasher unit and last but not least also the main light switch. Still, the little green light is permanently on when I do a turn signal.
So what else can cause the light to go on permanently? Broken wire somewhere? Or a broken rear light maybe?
Thank you very much for any input!
1939 Harley Davidson U
1944 Harley Davidson WLA
1944 Willys MB
1969 Ford Mutt A1
1973 AM General Mutt A2

muttguru
Colonel
Colonel
Posts: 1709
Joined: November 26th, 2007, 12:18 pm
Location: Li'l ol' England.....

Re: Turn signal light permanently on

Post by muttguru » May 27th, 2018, 2:30 pm

on-to-berlin wrote: So what else can cause the light to go on permanently? Broken wire somewhere? Or a broken rear light maybe?
Thank you very much for any input!
OTB....are you using the right bulb? The correct one should be No.1873, 3 candlepower, 28volt, 5.6 watt.
The UK-Europe equivalent is No.249, MCC, BA9S which is rated at 4 watt.
The wrong-value bulb can cause problems with the flasher unit and it can also cause the green lens to melt.
ken
Kind regards....
Ken

Always wanted - Details and pictures of M416 Trailer data plates & M151 data plates & body-tags for my research. Thanks!

Contact address - - muttguru@aol.com

Note for 2019..... Ken...get out more....

on-to-berlin
Sergeant First Class
Sergeant First Class
Posts: 236
Joined: December 1st, 2011, 1:54 pm

Re: Turn signal light permanently on

Post by on-to-berlin » May 27th, 2018, 3:35 pm

Ken,
it used to flash nicely since restauration was finished. And then all of a sudden it was permanently green.
What do you think it could be?
1939 Harley Davidson U
1944 Harley Davidson WLA
1944 Willys MB
1969 Ford Mutt A1
1973 AM General Mutt A2

rickf
General
General
Posts: 15949
Joined: November 26th, 2007, 1:28 pm
Location: Pemberton, NJ.

Re: Turn signal light permanently on

Post by rickf » May 27th, 2018, 4:31 pm

It would be related to the flasher unit and not the flasher switch up on the column. If the bulb is lit on the indicator on the column that just means the bulb is good. If it is not flashing then there is a problem with the flasher on the floor or you have lights out on the vehicle. Actually I think it will flash even with lights out on the vehicle, I will have to check that on mine. Check the ground wire on the flasher unit on the floor and make sure it has a good connection to bare metal.
1964 M151A1
1984 M1008
1967 M416
04/1952 M100
12/1952 M100- Departed
AN/TSQ-114A Trailblazer- Gone

on-to-berlin
Sergeant First Class
Sergeant First Class
Posts: 236
Joined: December 1st, 2011, 1:54 pm

Re: Turn signal light permanently on

Post by on-to-berlin » May 28th, 2018, 12:07 pm

Rick, you were right. I took another flasher and installed it and it worked.
On the wiring there was no ground wire. All the wires from the flasher went into the harness. On my A1 however, there is a ground wire.
Strange since the old flasher also was brand new. But the before it failed the flashing interval also was shorter then normal.
Anyways, this is why I like this forum!
Thank you for the help!
1939 Harley Davidson U
1944 Harley Davidson WLA
1944 Willys MB
1969 Ford Mutt A1
1973 AM General Mutt A2

Post Reply